Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » The Grudge Corner




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: H240x pump died.
 Post Posted: August 29th, 2015, 10:49 am 
Offline

Joined: August 28th, 2015, 9:09 pm
Posts: 1
After about a week or two of fine usage, my pc suddenly shut down due to overheating. I'm pretty sure the pump has died on my h240x. I don't see any movement or here any noise when turning it on. What are my option to help fix this issue?

I have emailed Bryan about 24 hours and havent got a reply yet. I really need some assistance with this issue. Either and rma or a refund.


Top 
 Profile  
 
 Post subject: Re: H240x pump died.
 Post Posted: August 31st, 2015, 8:37 am 
Offline
User avatar

Joined: January 17th, 2013, 4:53 pm
Posts: 2084
Frozen3201 wrote:
After about a week or two of fine usage, my pc suddenly shut down due to overheating. I'm pretty sure the pump has died on my h240x. I don't see any movement or here any noise when turning it on. What are my option to help fix this issue?

I have emailed Bryan about 24 hours and havent got a reply yet. I really need some assistance with this issue. Either and rma or a refund.


We're closed on the weekends and this is why I haven't responded to your email yet. I'll look at it and respond to you shortly.

Regards,

_________________
Bryan Ramirez, Swiftech Customer Support Team


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » User’s Questions & Discussions » The Grudge Corner


Who is online

Users browsing this forum: Google [Bot] and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: