Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » The Grudge Corner




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Missing mounting hardware
 Post Posted: April 26th, 2015, 10:20 am 
Offline

Joined: April 26th, 2015, 8:24 am
Posts: 1
So about two weeks ago I received the H220x AIO that I ordered. I went to install it, and realized that the LGA 2011 mounting kit had 3 screws for the 2011 and one for AMD mounting. I realized it was probably an honest mistake by the person who packaged the kit.

Since it wasn't a major issue, I called Swiftech and spoke spoke with Bryan, who issued an RMA and said a new kit would be sent out. I figured it was easier for them to send me some small hardware as opposed to sending the whole thing back on an RMA.

A few days later I followed up with him, and he said he didn't handle RMA processing or shipping and that he CC'd Chayenne.

A few days later I emailed her directly, no reply. I called two days later and spoke directly with her on the phone, she said it would be sent out, and I would be emailed a tracking.

It's been two weeks without this being resolved and I'm starting to get rather annoyed. Compared to other peoples issues this seems rather minor- but seriously, how (insert expletive here) difficult is it to send out a bag with mounting hardware, and a follow up email w/ tracking number?


Top 
 Profile  
 
 Post subject: Re: Missing mounting hardware
 Post Posted: April 27th, 2015, 10:43 am 
Offline
User avatar

Joined: January 17th, 2013, 4:53 pm
Posts: 2084
DamienSaint wrote:
So about two weeks ago I received the H220x AIO that I ordered. I went to install it, and realized that the LGA 2011 mounting kit had 3 screws for the 2011 and one for AMD mounting. I realized it was probably an honest mistake by the person who packaged the kit.

Since it wasn't a major issue, I called Swiftech and spoke spoke with Bryan, who issued an RMA and said a new kit would be sent out. I figured it was easier for them to send me some small hardware as opposed to sending the whole thing back on an RMA.

A few days later I followed up with him, and he said he didn't handle RMA processing or shipping and that he CC'd Chayenne.

A few days later I emailed her directly, no reply. I called two days later and spoke directly with her on the phone, she said it would be sent out, and I would be emailed a tracking.

It's been two weeks without this being resolved and I'm starting to get rather annoyed. Compared to other peoples issues this seems rather minor- but seriously, how (insert expletive here) difficult is it to send out a bag with mounting hardware, and a follow up email w/ tracking number?


Please email Chayenne directly at chayenne@swiftech.com. She will look into this for you and get back to you with a tracking number.

Regards,

_________________
Bryan Ramirez, Swiftech Customer Support Team


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » User’s Questions & Discussions » The Grudge Corner


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron