Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » The Grudge Corner




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: First the H220 breaks and now no response from Swiftech.
 Post Posted: April 4th, 2015, 5:20 am 
Offline

Joined: April 3rd, 2015, 4:15 pm
Posts: 3
So here is the full story,
I bought the H220 after doing a lot of online research where I found great reviews for this watercooling kit.
I've been using for a year and then suddenly it stopped working for no apparent reason. My PC setup didn't change at all during the whole year. Naturally I immediately went online on this forum, found others with the same problem and contacted Bryan Ramirez (swiftech support) in order to find a solution.
After following instructions given to me by swiftech support they decided that my pump was in fact dead and I should go for through the RMA process. So far so good (beside my disappointment for the hardware failure), the customer support was very friendly and quick to respond.

HERE is where the problem start. Since I live in Europe I was told the RMA will be handled by their EU distributor, they (US customer service) would contact their European team and have them contact me.
It's been three weeks and I haven't heard from any of them. After reading through the forum it seems I'm not the only customer angered by their lack of speed in RMA procedures.
I re-emailed Bryan (US customer service) a couple days ago and no answer from him either.

I started with patience but I'm running out of it. I had to use a Intel stock cooler and I'm worried it may damage my CPU.

As I asked in my last email I would like this situation resolved as soon as possible and if their EU distributor can't do this they should take care of it from the US.


Top 
 Profile  
 
 Post subject: Re: First the H220 breaks and now no response from Swiftech.
 Post Posted: April 6th, 2015, 10:09 am 
Offline
User avatar

Joined: January 17th, 2013, 4:53 pm
Posts: 2084
JasonPap wrote:
So here is the full story,
I bought the H220 after doing a lot of online research where I found great reviews for this watercooling kit.
I've been using for a year and then suddenly it stopped working for no apparent reason. My PC setup didn't change at all during the whole year. Naturally I immediately went online on this forum, found others with the same problem and contacted Bryan Ramirez (swiftech support) in order to find a solution.
After following instructions given to me by swiftech support they decided that my pump was in fact dead and I should go for through the RMA process. So far so good (beside my disappointment for the hardware failure), the customer support was very friendly and quick to respond.

HERE is where the problem start. Since I live in Europe I was told the RMA will be handled by their EU distributor, they (US customer service) would contact their European team and have them contact me.
It's been three weeks and I haven't heard from any of them. After reading through the forum it seems I'm not the only customer angered by their lack of speed in RMA procedures.
I re-emailed Bryan (US customer service) a couple days ago and no answer from him either.

I started with patience but I'm running out of it. I had to use a Intel stock cooler and I'm worried it may damage my CPU.

As I asked in my last email I would like this situation resolved as soon as possible and if their EU distributor can't do this they should take care of it from the US.


I'm sorry for not seeing your email before. We have a new procedure for dealing with these and I've sent you an email with the details. I'm sorry for this delay and please let me know if you need any further assistance.

Regards,

_________________
Bryan Ramirez, Swiftech Customer Support Team


Top 
 Profile  
 
 Post subject: Re: First the H220 breaks and now no response from Swiftech.
 Post Posted: May 4th, 2015, 5:09 am 
Offline

Joined: April 3rd, 2015, 4:15 pm
Posts: 3
UPDATE:
It's been almost a month since Swiftech support gave me an RMA number I needed to contact the European distributor. I contacted them immediately but didn't had any answers for a week, then they sent me an email with details on what should I do to proceed with the RMA. The problem is they are not used to dealing with customers (they mostly deal with retailers I guess) so the email they send me didn't make sense for me. I tried to contact them and it took several emails and finally a phone call to clarify the information. Package was sent right away and delivered to them more than a week ago and despite my emails no acknowledgment from their part is given on the status of the RMA. So I just called the EU distributor and I was told by a guy who had no idea about the RMA that it should now be in the procedure but they don’t have any ETA, in fact he told me "it's random, depending on the manufacturer".

I'll update again when there will be more news (good I hope).


Top 
 Profile  
 
 Post subject: Re: First the H220 breaks and now no response from Swiftech.
 Post Posted: June 6th, 2015, 12:53 am 
Offline

Joined: April 3rd, 2015, 4:15 pm
Posts: 3
FINAL UPDATE:
I received my replacement H220 cooler a week ago and installed it right away. It is operating normally since then. This morning when I turned on my PC I got a “CPU Fan Error” message and freaked out, with a reboot it was gone and I really hope that this was some kind of false negative and it won’t ever happen again (this was the same message I got when my first H220 pump died). It took 3 months to go through the RMA procedure making it the worst customer service experience I ever had. Finally I hope I won’t have to write here again about a new miss function of the Swiftech hardware.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 4 posts ] 

Board index » User’s Questions & Discussions » The Grudge Corner


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron