Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » The Grudge Corner




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: H220 RMA, no response......
 Post Posted: December 5th, 2014, 6:12 pm 
Offline

Joined: August 30th, 2014, 10:10 pm
Posts: 2
viewtopic.php?f=23&t=2658.

Sent Bryan an email to help@swiftech, and his email. No responses about shipping label, nothing. This was in September.


Top 
 Profile  
 
 Post subject: Re: H220 RMA, no response......
 Post Posted: December 6th, 2014, 1:36 am 
Offline
User avatar

Joined: January 17th, 2013, 4:53 pm
Posts: 2084
vividstrains wrote:
http://forums.swiftech.org/viewtopic.php?f=23&t=2658.

Sent Bryan an email to help@swiftech, and his email. No responses about shipping label, nothing. This was in September.


You should have received the shipping label by now. Please check your spam and junk folders because these labels are generated by UPS and sometimes they can end up there. Please email me though if this isn't the case and I'll make sure to have another one sent to you on Monday when I get back into work.

Regards,

_________________
Bryan Ramirez, Swiftech Customer Support Team


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » User’s Questions & Discussions » The Grudge Corner


Who is online

Users browsing this forum: No registered users and 2 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron