Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » The Grudge Corner




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: H220 killed my system
 Post Posted: July 19th, 2014, 1:42 pm 
Offline

Joined: July 14th, 2014, 6:45 pm
Posts: 3
I emailed support about a couple a months ago with the buzzing issue. Bryan told me it was fine and that I can't get an RMA. The issue got worse, so I tried contacting again because I knew something had to be wrong. I didn't get any response. Today, my unit leaked and killed my GPU and possibly my CPU and motherboard. I have tried calling and emailing, and got no response even though you say on your hours that you are open at the time of calling.

This is just unacceptable. The issue was ignored until it got worse and brought down my system with it. Along with that, EVGA responded immediately to my RMA request, and I will probably have my GPU shipped out within the next day. Swiftech hasn't even responded, and it was a Swiftech product that caused all this. I demand an RMA because this could have all been avoided. You ignored me once, but now I will not accept any sort of excuse.

Sincerely,
Hank


Top 
 Profile  
 
 Post subject: Re: H220 killed my system
 Post Posted: July 20th, 2014, 1:53 pm 
Offline
User avatar

Joined: January 17th, 2013, 4:53 pm
Posts: 2084
KooKilla wrote:
I emailed support about a couple a months ago with the buzzing issue. Bryan told me it was fine and that I can't get an RMA. The issue got worse, so I tried contacting again because I knew something had to be wrong. I didn't get any response. Today, my unit leaked and killed my GPU and possibly my CPU and motherboard. I have tried calling and emailing, and got no response even though you say on your hours that you are open at the time of calling.

This is just unacceptable. The issue was ignored until it got worse and brought down my system with it. Along with that, EVGA responded immediately to my RMA request, and I will probably have my GPU shipped out within the next day. Swiftech hasn't even responded, and it was a Swiftech product that caused all this. I demand an RMA because this could have all been avoided. You ignored me once, but now I will not accept any sort of excuse.

Sincerely,
Hank


Hi again Hank,

Unfortunately we're closed on the weekends. I'll take care of your issue when I get into work in the morning. This is very unusual for one of these kits to leak though because they're all vacuum filled and pressure tested prior to being shipped from the factory. I'll discuss it with you tomorrow when I get into work and I"m very sorry about this issue.

Regards,

_________________
Bryan Ramirez, Swiftech Customer Support Team


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » User’s Questions & Discussions » The Grudge Corner


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron