Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » Liquid Cooling




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: H240-X2 leaking at pump outlet!
 Post Posted: March 3rd, 2017, 7:18 am 
Offline

Joined: March 3rd, 2017, 4:14 am
Posts: 1
Hi All

I have just installed a Swiftech H240-X2 cooler in a new system, and on first test in the case I found that there is a leak at the outlet from the pump. The leak is coming out from between the clear acrylic housing and the metal plate that the hose connections are connected to. I have attached two photos showing the location.


Image
First is a general view showing what I'm looking at.

Image
Second is a close up of where it is leaking. I have circled the location of the leak, it is between the flat metal plate and the clear acrylic. The leak is on both the visible side, and the opposite side, around the same distance either side of the screw. I have also circled, in blue, what I think may be a crack in the plastic, which I noticed after reviewing the photograph. I am concerned that this may also leak.

Is this an issue that I may be able to correct, or will I need to return it under warranty? There are two screws holding the plate onto the acrylic, can these be tightened or would this risk damaging the unit (or voiding the warranty)?

I should point out that the unit was purchased from PC Case Gear in Melbourne, Australia, so I would need to prove the issue to them to be able to take it back under warranty, in particular as I am unsure if the unit can be run outside of a computer case (the provided instructions do not specify if this is possible or not). I am very concerned about this leak, as it does pose a risk to other components in the computer when I test/run the computer.

I did find some 'condensation' in the bag when we opened the unit, however this appeared to simply be condensation, as the unit was purchased and opened on a hot day (we are currently in summer weather here). It was only after the first test that I found the leak.

The date on the reservoir is 16.08.30 (30th August 2016). The unit was purchased on the 15th of February 2017.

Thanks
Cdatar


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 1 post ] 

Board index » User’s Questions & Discussions » Liquid Cooling


Who is online

Users browsing this forum: No registered users and 4 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron