Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » Liquid Cooling




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Drain/Refill H320 x2 Prestige first time!
 Post Posted: May 3rd, 2016, 2:23 pm 
Offline

Joined: June 20th, 2013, 8:20 am
Posts: 6
Hey guys, it's my first time ever doing this. I'm going to follow the tips in this video per swiftech: https://www.youtube.com/watch?v=0fpum4J6C2k I'm changing the dye so I need to drain/refill.

1) what coolant/fluid is used on the H320 x2 prestige so I can purchase the same one?

2) can I use the power supply jumpstart connector that came with my EVGA G2 850 Supernova even though I am using cableMod individual sleevedcables now? (same PSU though)
http://www.evga.com/Products/Product.aspx?pn=220-G2-0850-XR
https://cablemod.com/product/cablemod-e-series-g2-p2-cable-kit-black-red/

3) When attaching the PWM splitter to the h320 x2 (btw, which is the pump cable on the h320 x2?) , pwm splitter should be attached to the motherboard correct?

4) The PWM splitter should be attached to CPU_Fan on mobo, but everything else should be disconnected correct (i.e. usb 2.0, audio header, front panel/case LED/hdd led/PW reset, case fans) from motherboard correct? and obviously the power supply should be attached to the wall at this point? (after the jumpstart connector has been attached)

5) do I need to leave the PC online without anything connected to the mobo over night, even though I didn't change the tubes/fittings/etc.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 1 post ] 

Board index » User’s Questions & Discussions » Liquid Cooling


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: