Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » Liquid Cooling




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: H240 X2 Pump Noise
 Post Posted: April 12th, 2016, 6:21 am 
Offline

Joined: April 12th, 2016, 5:35 am
Posts: 3
Just bought and installed the new H240 X2, only to find out that it emits a loud buzzing/humming noise. It doesn't sound like anything is broken or anything, it just sounds consistently VERY loud.

I heard you can manually turn down the pump speed to reduce the noise, but is that really something I should consider? How can I do this?

Thanks.

Link to pump noise if this helps: https://www.youtube.com/watch?v=SsrZZjWkVPU


Top 
 Profile  
 
 Post subject: Re: H240 X2 Pump Noise
 Post Posted: April 15th, 2016, 6:01 am 
Offline

Joined: April 13th, 2016, 2:43 am
Posts: 4
I just received and installed the h240 X2 prestige, I was shocked at how loud the pump is , I was actually replacing an old faulty AIO from cooler master because the noise was bugging me and this one is even louder! When i received mine the plastic it comes in was all wet also so I'm hoping its just damaged , I contacted swiftech in 3 different ways , no reply and I had dried up my h240x2 ,checked if it got wet again , it wasn't so put it in for test drive but man that pump is ridiculously loud.... still waiting on response from swiftech


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » User’s Questions & Discussions » Liquid Cooling


Who is online

Users browsing this forum: No registered users and 3 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: