Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » Technical support




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: H220 x2 Noise Question - with video
 Post Posted: January 14th, 2017, 1:08 pm 
Offline

Joined: January 14th, 2017, 12:19 pm
Posts: 2
Greetings!

I'm trying to determine if the noise from my H220 x2 is a common sound for the H220 x2 and/or water pumps in general.

https://youtu.be/_TvPP3SoknM

If this noise is typical of the H220 x2 pump, are there pumps that don't make a high pitched noise?

LED problems seem very common. It would seem the LEDs on the reservoir are probably user replaceable without draining the system. What is required to replace the LEDs in the cpu block?

I will use this information to determine whether I want to try another Swiftech unit, a different brand of liquid, or a low-profile, small-footprint air cooler.

Thanks for any suggestions!

Additional Background:
Note, I have to use slim 120 x 20mm fans to fit most slim radiators in my case.

1st: H100i v2: Installed and had very good results. CPU idle temps were within 1 to 3C of ambient. Unfortunately, the unit I had was noisy when mounted to a horizontally oriented motherboard. I'm running an itx z170 board in a Corsair 250d. Putting the PC on its side effectively eliminated pump noise. The h100i v2 was returned.

2nd: H220 x2: Installed with so-so results. CPU idle temps are comparable to the H100i v2. Block LEDs died after a CPU swap. Pump / gear noise is pretty annoying. With the case panels on it is dampened, but still noticeable.


Top 
 Profile  
 
 Post subject: Re: H220 x2 Noise Question - with video
 Post Posted: January 14th, 2017, 5:25 pm 
Offline

Joined: January 14th, 2017, 12:19 pm
Posts: 2
The pump sounds very much like the chatter of a hard drive! I didn't make the connection until I pulled out an old hdd to transfer my steam library from the old pc to the new one.

Since my post earlier, the some of the LEDs on the reservoir have decided to turn green.

I don't really need support anymore. I'm just going to return the unit to the seller.

Unfortunately, even if the pump noise is normal or can be remedied, the aesthetics rely heavily on LEDs. Given that LED problems seem so common, I'm not confident that I'll get a trouble-free unit.

:(


Top 
 Profile  
 
 Post subject: Re: H220 x2 Noise Question - with video
 Post Posted: January 16th, 2017, 12:51 pm 
Offline
User avatar

Joined: August 29th, 2016, 8:40 am
Posts: 39
hey,

sorry for the issue that is occuring.
please contact me at my email so i can get this matter resolve for you: help@swiftech.com

thanks

_________________
Regards,
MAC
RMA DEPARTMENT / CUSTOMER SUPPORT


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 3 posts ] 

Board index » User’s Questions & Discussions » Technical support


Who is online

Users browsing this forum: No registered users and 5 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron