Register    Login    Forum    Search    FAQ

Board index » Swiftech Communications » Technical Bulletins




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: KOMODO 5800 SERIES (ATI)
 Post Posted: February 2nd, 2010, 9:46 pm 
Offline
User avatar

Joined: January 24th, 2007, 4:35 pm
Posts: 258
Location: Lakewood, CA
Issue:
No graphics display after installation of the Komodo HD5800 (black screen). This is a random occurence, and no permanent damage to the card is expected.

Cause:
Overtightening of the 4 screws fastening the stock spring-backplate.

Field/user resolution:
Uninstalling the block is not necessary.
Backing off the 4 screws by a minimum of 1 turn, and not to exceed 2 turns (an equal amount of turns for each screw is essential) resolves the issue, and restores graphics functionality.

Scope:
This issue may affect all water-blocks shipped between December 1st, 2009 and January 31st, 2010.

Production Resolution:
Effective February 1st, 2010, inclusion of a nylon washer between board and spring back-plate prevents overtightening of the spring back-plate. Installation guide was revised accordingly.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 1 post ] 

Board index » Swiftech Communications » Technical Bulletins


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron