Register    Login    Forum    Search    FAQ

Board index » User’s Questions & Discussions » Technical support




Post new topic  [ 1606 topics ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 33  Next
 Topics   Author   Replies   Views   Last post 
No unread posts Just received h240x2 prestige and its wet in the bag..advice

Abomb

2

971

April 18th, 2016, 12:51 pm

shanels View the latest post

No unread posts swiftech x2 220 compatiblity w/case/cpu?

boadicea

0

688

April 15th, 2016, 3:38 pm

boadicea View the latest post

No unread posts Can't unscrew backplate H240 x2 prestige

Codyp76

0

716

April 14th, 2016, 12:12 pm

Codyp76 View the latest post

No unread posts User Guide

mirohh

0

659

April 14th, 2016, 11:48 am

mirohh View the latest post

No unread posts Tech support Unresponsive

HBrown140

0

688

April 11th, 2016, 7:22 am

HBrown140 View the latest post

No unread posts H320 X-2 Prestige Dead Connectors

rmichuda

0

537

April 9th, 2016, 8:33 am

rmichuda View the latest post

No unread posts User error

LH9060

1

537

April 9th, 2016, 1:37 am

LH9060 View the latest post

No unread posts H220X Leaking from screws under resivoir

Dman24

3

1223

April 8th, 2016, 5:15 am

mcnumpty23 View the latest post

No unread posts H220 X2 - Strange LED Issue

Tweek78

2

1076

April 6th, 2016, 4:57 pm

HiTach View the latest post

No unread posts Is this normal, or should i not use it and get it replaced.

BURNTHEDEAD

3

1259

April 5th, 2016, 2:19 pm

mcnumpty23 View the latest post

No unread posts H220X2 discoloration

AustinGorski

0

660

April 4th, 2016, 5:11 pm

AustinGorski View the latest post

No unread posts Warm pipe / CPU overheating problems

james93

0

640

April 3rd, 2016, 4:37 am

james93 View the latest post

No unread posts h220 combatability with 2011v3

Ron

0

715

March 31st, 2016, 11:07 pm

Ron View the latest post

No unread posts h240-x cracked window

mcnumpty23

0

722

March 31st, 2016, 4:40 pm

mcnumpty23 View the latest post

No unread posts Start up Fans And Pump run on full speed on H320X2 prestige

MickWizz

2

942

March 30th, 2016, 10:05 am

DangoPC View the latest post

No unread posts Constant high frequency ticking noise from H140X pump [Help]

bla58

0

668

March 28th, 2016, 1:48 pm

bla58 View the latest post

No unread posts Has installing new cooler damaged motherboard?

gordonhutchison

1

901

March 28th, 2016, 11:21 am

MickWizz View the latest post

No unread posts H220-X2: LEDs and Fans not working

Tb64

3

1559

March 27th, 2016, 1:35 am

Vihsadas View the latest post

No unread posts Dead Swiftech MCP50X

hevnbnd

0

691

March 25th, 2016, 4:48 pm

hevnbnd View the latest post

No unread posts MCW82 on GTX970

autotalon

0

694

March 22nd, 2016, 2:25 pm

autotalon View the latest post

No unread posts H220 X2 Prestige - Leaking rubber L connector

Crushader

0

774

March 22nd, 2016, 3:21 am

Crushader View the latest post

No unread posts Komodo HD7950

Freeflow

0

670

March 20th, 2016, 4:09 pm

Freeflow View the latest post

No unread posts Noiseblocker NB eLoop 140mm Clicking

proppaganda

2

1229

March 18th, 2016, 10:34 pm

proppaganda View the latest post

No unread posts How tight should cpu block be screwed down on H220X?

Pipdrums

2

1320

March 17th, 2016, 9:45 am

Pipdrums View the latest post

No unread posts Second H240 X2 that arrived leaking in the box

Menthol

0

938

March 17th, 2016, 3:53 am

Menthol View the latest post

No unread posts H240 X2 PWM Controller Problem, Maybe?

4tehlolxz

0

806

March 17th, 2016, 1:02 am

4tehlolxz View the latest post

No unread posts H320 X2 Prestiege

MendoRugger

2

1028

March 16th, 2016, 3:48 pm

DangoPC View the latest post

No unread posts Leak Test before installing H220 X

Pipdrums

1

946

March 11th, 2016, 11:57 am

DangoPC View the latest post

No unread posts KOMODO R9 LE waterblock leaking

Hawck

1

941

March 10th, 2016, 3:03 am

Hawck View the latest post

No unread posts Crack in reservoir window H240x

EvilCake

1

1101

March 9th, 2016, 12:34 pm

DangoPC View the latest post

No unread posts H140-X: Gurgling sound

jvangorkum

4

1364

March 9th, 2016, 12:33 pm

DangoPC View the latest post

No unread posts H320 1150 to 2011-3

TimDrake

0

694

March 8th, 2016, 11:30 am

TimDrake View the latest post

No unread posts H240x bubbling noise

coolusername

1

926

March 7th, 2016, 9:46 am

DangoPC View the latest post

No unread posts H240-X2 reservoir led doesn't work

GuraSan

3

1105

March 5th, 2016, 2:10 pm

GuraSan View the latest post

No unread posts H220 X2 fan configuration

ToasterMe

0

717

March 5th, 2016, 9:39 am

ToasterMe View the latest post

No unread posts komodo nv titanx compatibility check

CRAKZOR

0

803

March 4th, 2016, 12:21 pm

CRAKZOR View the latest post

No unread posts Swiftech 8 Way PWM Splitter wont work on sysfan

mbwdekeijzer

2

910

March 4th, 2016, 11:17 am

mbwdekeijzer View the latest post

No unread posts New H220 X2 - Check no leaks - Run 'standalone'? [Solved]

Hotshot

2

922

March 4th, 2016, 3:15 am

Hotshot View the latest post

No unread posts New 320 no leds

Tabakki

5

1344

March 3rd, 2016, 6:05 pm

Tabakki View the latest post

No unread posts New H240x with brown mud in the reservoir out of the box!

Dem

4

1522

March 3rd, 2016, 4:09 pm

DangoPC View the latest post

No unread posts H220X Leaking

MitchellG

1

791

March 3rd, 2016, 4:08 pm

DangoPC View the latest post

No unread posts Swiftech H240 X2 LEDs

cobhc85

2

875

March 3rd, 2016, 11:32 am

DangoPC View the latest post

No unread posts H220x Pump Rattle

Osirez

1

774

March 3rd, 2016, 11:21 am

DangoPC View the latest post

No unread posts Got my replacement, new 240-x but now cloudy resorvoir

Saintage

2

995

March 3rd, 2016, 5:20 am

Kellin View the latest post

No unread posts H220-X Reservoir build up

LiveZero

6

1580

March 1st, 2016, 3:45 pm

LiveZero View the latest post

No unread posts H320 X2 Prestige - Pump DOA

Ivan

1

987

March 1st, 2016, 3:43 pm

Aisenheim View the latest post

No unread posts H220x X2 Prestige series

TobiasR1989

3

1082

February 29th, 2016, 11:34 am

TobiasR1989 View the latest post

No unread posts H220 Liquid Cooler ratling noise

mogs91

2

861

February 29th, 2016, 4:56 am

IvanoFFst View the latest post

No unread posts H220: CPU Fan error

Pahcixam

1

844

February 26th, 2016, 5:23 pm

DangoPC View the latest post

No unread posts Drive X2 series LED control and availability question

damian21

2

901

February 26th, 2016, 1:38 pm

damian21 View the latest post

Display topics from previous:  Sort by  
 
Post new topic  [ 1606 topics ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 33  Next

Board index » User’s Questions & Discussions » Technical support


Who is online

Users browsing this forum: No registered users and 3 guests

 
 

Unread posts Unread posts    No unread posts No unread posts    Announce Announcement
Unread posts [ Popular ] Unread posts [ Popular ]    No unread posts [ Popular ] No unread posts [ Popular ]    Sticky Sticky
Unread posts [ Locked ] Unread posts [ Locked ]    No unread posts [ Locked ] No unread posts [ Locked ]    Moved topic Moved topic
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron