Register    Login    Forum    Search    FAQ

Board index » View unanswered posts


View unanswered posts

Search
   Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. H240x2 pump clicking noise (not constant)

in Technical support

FraggleRock

0

784

June 20th, 2016, 1:32 am

FraggleRock View the latest post

There are no new unread posts for this topic. Help!

in Liquid Cooling

eruv

0

1033

June 17th, 2016, 11:51 am

eruv View the latest post

There are no new unread posts for this topic. H220-X Heavy Pump Hum

in Technical support

PSmyth

0

825

June 16th, 2016, 7:53 am

PSmyth View the latest post

There are no new unread posts for this topic. Swiftech Apogee Drive II - Light doesnt work

in Technical support

m1am1

0

689

June 14th, 2016, 7:18 am

m1am1 View the latest post

There are no new unread posts for this topic. H240 X2 Leaked

in Technical support

HaiYen

0

955

June 12th, 2016, 6:04 am

HaiYen View the latest post

There are no new unread posts for this topic. replacement pump and reservoir

in Technical support

ortondale

0

764

June 10th, 2016, 3:08 am

ortondale View the latest post

There are no new unread posts for this topic. mcp35x 2 dual x psu shuttdown

in Technical support

darksidevirus

0

695

June 5th, 2016, 1:08 pm

darksidevirus View the latest post

There are no new unread posts for this topic. H220 x2 Dead pump?

in Technical support

conalds

0

770

June 4th, 2016, 5:02 am

conalds View the latest post

There are no new unread posts for this topic. H140-X Quality

in Technical support

Qwerty1zer

0

607

May 29th, 2016, 4:51 pm

Qwerty1zer View the latest post

There are no new unread posts for this topic. New H220 X2 Fans spin sporatically

in Technical support

ntruhan

0

634

May 25th, 2016, 10:41 am

ntruhan View the latest post

There are no new unread posts for this topic. H220 Tubing Size

in Technical support

Skiiwee29

0

653

May 21st, 2016, 7:18 pm

Skiiwee29 View the latest post

There are no new unread posts for this topic. Building water cooling system from ground up

in Technical support

dot4xdash

0

655

May 18th, 2016, 6:07 pm

dot4xdash View the latest post

There are no new unread posts for this topic. Leak Issues with H240X2 Prestiges

in Technical support

shanels

0

839

May 15th, 2016, 9:11 am

shanels View the latest post

There are no new unread posts for this topic. Is MCP50X air or liquid cooled?

in Liquid Cooling

goletz

0

835

May 11th, 2016, 3:30 am

goletz View the latest post

There are no new unread posts for this topic. Drain/Refill H320 x2 Prestige first time!

in Liquid Cooling

reflexez

0

1213

May 3rd, 2016, 2:23 pm

reflexez View the latest post

There are no new unread posts for this topic. @ Swiftech... Thanks again for a great product.

in Liquid Cooling

thedarkdad3

0

940

April 29th, 2016, 8:41 pm

thedarkdad3 View the latest post

There are no new unread posts for this topic. H320 X2 LGA 1366 Installation

in Technical support

misomeru

0

746

April 28th, 2016, 10:32 pm

misomeru View the latest post

There are no new unread posts for this topic. H240 X2 Pump Failure

in Technical support

ExRayz

0

805

April 25th, 2016, 6:20 am

ExRayz View the latest post

There are no new unread posts for this topic. Need help with new loop set up.

in Liquid Cooling

Madmaxneo

0

869

April 22nd, 2016, 1:23 pm

Madmaxneo View the latest post

There are no new unread posts for this topic. Swiftech Philippine Distributor/Reseller

in Technical support

xXLXx

0

768

April 20th, 2016, 6:59 am

xXLXx View the latest post

There are no new unread posts for this topic. Problem with a fan in H240-X CPU Liquid Cooling KiT

in Technical support

scorpion359

0

702

April 20th, 2016, 5:08 am

scorpion359 View the latest post

There are no new unread posts for this topic. swiftech x2 220 compatiblity w/case/cpu?

in Technical support

boadicea

0

779

April 15th, 2016, 3:38 pm

boadicea View the latest post

There are no new unread posts for this topic. Can't unscrew backplate H240 x2 prestige

in Technical support

Codyp76

0

809

April 14th, 2016, 12:12 pm

Codyp76 View the latest post

There are no new unread posts for this topic. User Guide

in Technical support

mirohh

0

739

April 14th, 2016, 11:48 am

mirohh View the latest post

There are no new unread posts for this topic. H240-X & H140-X pump upgrades

in Liquid Cooling

JAMESZ28

0

900

April 14th, 2016, 6:47 am

JAMESZ28 View the latest post

There are no new unread posts for this topic. Leak Testing Expanded 240-X2

in Liquid Cooling

marshall91t

0

959

April 13th, 2016, 5:03 am

marshall91t View the latest post

There are no new unread posts for this topic. changing dye color of h320 x2 prestige?

in Liquid Cooling

reflexez

0

973

April 13th, 2016, 3:17 am

reflexez View the latest post

There are no new unread posts for this topic. Tech support Unresponsive

in Technical support

HBrown140

0

773

April 11th, 2016, 7:22 am

HBrown140 View the latest post

There are no new unread posts for this topic. MCP50X not running

in Liquid Cooling

leeturbo

0

751

April 11th, 2016, 1:02 am

leeturbo View the latest post

There are no new unread posts for this topic. H320 X-2 Prestige Dead Connectors

in Technical support

rmichuda

0

602

April 9th, 2016, 8:33 am

rmichuda View the latest post

There are no new unread posts for this topic. MCP50X clicking sound

in Liquid Cooling

acidkhmer

0

701

April 8th, 2016, 7:22 am

acidkhmer View the latest post

There are no new unread posts for this topic. How do i overclock i5-4670k?

in Overclocking

B1GF31N

0

1060

April 5th, 2016, 5:21 pm

B1GF31N View the latest post

There are no new unread posts for this topic. H220X2 discoloration

in Technical support

AustinGorski

0

743

April 4th, 2016, 5:11 pm

AustinGorski View the latest post

There are no new unread posts for this topic. Warm pipe / CPU overheating problems

in Technical support

james93

0

721

April 3rd, 2016, 4:37 am

james93 View the latest post

There are no new unread posts for this topic. h220 combatability with 2011v3

in Technical support

Ron

0

784

March 31st, 2016, 11:07 pm

Ron View the latest post

There are no new unread posts for this topic. h240-x cracked window

in Technical support

mcnumpty23

0

806

March 31st, 2016, 4:40 pm

mcnumpty23 View the latest post

There are no new unread posts for this topic. Constant high frequency ticking noise from H140X pump [Help]

in Technical support

bla58

0

742

March 28th, 2016, 1:48 pm

bla58 View the latest post

There are no new unread posts for this topic. New H320 X2 Installed!

in Liquid Cooling

watsoncomputers

0

906

March 26th, 2016, 5:22 pm

watsoncomputers View the latest post

There are no new unread posts for this topic. Dead Swiftech MCP50X

in Technical support

hevnbnd

0

761

March 25th, 2016, 4:48 pm

hevnbnd View the latest post

There are no new unread posts for this topic. Switching the pump of H240-X

in Liquid Cooling

asterfenix

0

885

March 23rd, 2016, 4:16 pm

asterfenix View the latest post

There are no new unread posts for this topic. MCW82 on GTX970

in Technical support

autotalon

0

765

March 22nd, 2016, 2:25 pm

autotalon View the latest post

There are no new unread posts for this topic. First water cooling build. advices?

in Liquid Cooling

fael097

0

779

March 22nd, 2016, 1:48 pm

fael097 View the latest post

There are no new unread posts for this topic. H220 X2 Prestige - Leaking rubber L connector

in Technical support

Crushader

0

869

March 22nd, 2016, 3:21 am

Crushader View the latest post

There are no new unread posts for this topic. Komodo HD7950

in Technical support

Freeflow

0

751

March 20th, 2016, 4:09 pm

Freeflow View the latest post

There are no new unread posts for this topic. Second H240 X2 that arrived leaking in the box

in Technical support

Menthol

0

1023

March 17th, 2016, 3:53 am

Menthol View the latest post

There are no new unread posts for this topic. H240 X2 PWM Controller Problem, Maybe?

in Technical support

4tehlolxz

0

889

March 17th, 2016, 1:02 am

4tehlolxz View the latest post

There are no new unread posts for this topic. H220-X with 2ea R9 390s (No CPU)

in Liquid Cooling

mytime34

0

799

March 15th, 2016, 9:42 am

mytime34 View the latest post

There are no new unread posts for this topic. H320 1150 to 2011-3

in Technical support

TimDrake

0

778

March 8th, 2016, 11:30 am

TimDrake View the latest post

There are no new unread posts for this topic. Has installing new cooler damaged motherboard?

in Liquid Cooling

gordonhutchison

0

998

March 7th, 2016, 2:49 pm

gordonhutchison View the latest post

There are no new unread posts for this topic. H220 X2 fan configuration

in Technical support

ToasterMe

0

796

March 5th, 2016, 9:39 am

ToasterMe View the latest post

Display posts from previous:  Sort by:  
 
 
Page 3 of 12 [ Search found 562 matches ]


Board index » View unanswered posts


Jump to:  
cron